Syncing Issues

Fri Jun 26, 2015 8:49 am

Hello,

I'm in the process of creating a batch of promotional videos and ran in to a syncing issue.

Everything looks great! But I'm missing some impact, due to the fact that the visuals are a bit slower than the audio underneath it.

I've been reading the forum and saw that others were having the same issue;

You suggested that we export as png's.

But, what software would you suggest I use on OSX to merge the png's to a mp4, and how would one go about doing this?

A second issue that I'm dealing with is;

I have created a VISUAL TEMPLATE for my audio tracks, but when I choose to export the video or png's for that matter; it defaults to the time of the first imported audio. ie. I have to set the time of render manually for every audio track I would want to export. Are there work a rounds? Is this a bug?


Link to one of the rendered files:

[media]



By the way; great job on this software; I'm loving it! Very intuitive and inspirational.

Looking forward to your reply!
KainProject
 
Posts: 5
Joined: Fri Jun 26, 2015 8:41 am

Re: Syncing Issues

Fri Jun 26, 2015 10:26 pm

Your video looks perfectly synchronized to me :). If I had to guess, I'd say your monitor has some display lag. Someone else had a similar issue recently: viewtopic.php?f=2&t=435

Unfortunately, if that's the problem, your visuals will always appear to lag behind your audio, whether you're using Magic or any other video program. If possible, you might want to try using a different monitor to see if it fixes the problem.

I have created a VISUAL TEMPLATE for my audio tracks, but when I choose to export the video or png's for that matter; it defaults to the time of the first imported audio. ie. I have to set the time of render manually for every audio track I would want to export. Are there work a rounds? Is this a bug?

It's not a bug; I just didn't foresee people wanting to use Magic in that way. What I will do is add a button in the export window that will let you automatically update the export length based on the current audio length.
Eric
Site Admin
 
Posts: 3159
Joined: Wed Apr 09, 2014 9:28 pm

Re: Syncing Issues

Sat Jun 27, 2015 7:35 am

Hello Eric,

Thank you for the reply! I'm glad to see that you will add that extra option to the export window.

As for the syncing, I'm still not convinced that it would be because of my monitor; When I use a single waveform it's pretty spot on! It might have something to do with the smoothing.

I would like to have the logo pop out on kick drums; 60-280 'ish; I tried :

- size, but I can't seem to program it so that the image stays in its original size until the input tells it to grow / ie. it vanishes when there is no input.
(add modifier?, which one, I played around with some but couldn't figure this out.)
- Radial blur; what I'm using in the example: This does a good job but gives me some delay / sync because I have to use smooth to fine tune.

Could you suggest a way to simplify this action? grow image - from default size state ( very minimal like 5/10%, just to see the rhythm )
KainProject
 
Posts: 5
Joined: Fri Jun 26, 2015 8:41 am

Re: Syncing Issues

Sat Jun 27, 2015 5:12 pm

Ah, well the Smooth modifier does introduce a delay. The more smoothing, the higher the delay. Just the nature of how smoothing works in general. If you want a similar effect but without delay, you can try the Peak modifier, but it only smooths the release, not the attack. As with most things, it's a tradeoff.

If you only want to scale something up 10% in response to volume, try these modifiers:
Scale .1
Offset 1
They represent this equation: Volume * .1 + 1 = Final Value. Thus, a volume of 0 will result in 1, and a volume of 1 will result in 1.1.
Eric
Site Admin
 
Posts: 3159
Joined: Wed Apr 09, 2014 9:28 pm

Re: Syncing Issues

Sun Jun 28, 2015 1:11 pm

I think I found the sweet spot;

Thanks for the tip with the offset :) I've added Peak and Power and now I can really tune in the size increase and with a good response time.

My settings:
http://oi58.tinypic.com/4lqf42.jpg


What I'd still like to know is what software you would suggest for the merging of the png's on mac osx :)
KainProject
 
Posts: 5
Joined: Fri Jun 26, 2015 8:41 am

Re: Syncing Issues

Sun Jun 28, 2015 5:37 pm

What I'd still like to know is what software you would suggest for the merging of the png's on mac osx

This section in the User's Guide might be helpful: https://magicmusicvisuals.com/downloads/Magic_UsersGuide.html#VideoSoftware

If none of those options work for you, let me know and I'll try to think of some others.
Eric
Site Admin
 
Posts: 3159
Joined: Wed Apr 09, 2014 9:28 pm

Re: Syncing Issues

Sun Jun 28, 2015 5:55 pm

Ok, thank you.
KainProject
 
Posts: 5
Joined: Fri Jun 26, 2015 8:41 am

Re: Syncing Issues

Wed Apr 21, 2021 8:51 am

I'm running a two computer set up, magic and OBS on a new MBP M1 CHIP, SERATO Pro & mixemergency on a 2018 MBP. I'm using NDI on BOTH COMPUTERS. I can't get the audio and video to sync. I have record it and it plays back perfect, but when I go live the audio jumps ahead of the video any suggestions? I think it's in the obs settings .
DJLOUSKI
 
Posts: 1
Joined: Wed Apr 21, 2021 8:23 am

Re: Syncing Issues

Wed Apr 21, 2021 2:47 pm

Live video will almost always be behind live audio. Audio is much easier to transmit (especially using analog connections) and therefore has much less processing delay than video.
Eric
Site Admin
 
Posts: 3159
Joined: Wed Apr 09, 2014 9:28 pm

Re: Syncing Issues

Wed Apr 21, 2021 3:19 pm

Eric wrote:Live video will almost always be behind live audio ...


... so it's common to have an audio delay facility to compensate for this. I'm not an OBS user, but expected it to have this facility and indeed it does:
https://streamshark.io/obs-guide/audio-delay
Terry Payman
 
Posts: 624
Joined: Sun Sep 14, 2014 8:15 am
Location: UK

Re: Syncing Issues

Wed Apr 21, 2021 3:39 pm

Yes, that will work fine if you are only streaming. But if you are also playing to a live audience, it would be quite strange to delay the audio! ;)
Eric
Site Admin
 
Posts: 3159
Joined: Wed Apr 09, 2014 9:28 pm

Return to General Discussion

© 2021 Color & Music, LLC • This web site is mobile-friendly