Some pics are not played by "JPEG Folder" block

Wed Oct 02, 2019 5:02 pm

Hi, i have the next problem. I have a scene which has a "JPEG Folder" block, but not all the pictures are played, when a picture cant be played magic does a "blackout" however if i play one of those pics from an "Image" block it can be played.

Thanks for the help!!!
thedoger82
 
Posts: 3
Joined: Wed Oct 02, 2019 4:58 pm

Re: Some pics are not played by "JPEG Folder" block

Wed Oct 02, 2019 5:52 pm

The JpegFolder module requires a certain type of image format in order to be hardware accelerated.

If you can upload/attach an image that doesn’t work, I can test it for you.
Eric
Site Admin
 
Posts: 2636
Joined: Wed Apr 09, 2014 9:28 pm

Re: Some pics are not played by "JPEG Folder" block

Wed Oct 02, 2019 6:49 pm

Thank you thank you... Here you go...
Attachments
coder23 004.jpg
one of them
coder23 004.jpg (558.99 KiB) Viewed 360 times
thedoger82
 
Posts: 3
Joined: Wed Oct 02, 2019 4:58 pm

Re: Some pics are not played by "JPEG Folder" block

Thu Oct 03, 2019 2:18 pm

Yes, as I thought, that image has 4:1:1 chrominance subsampling, which means it is not fully hardware accelerated.

But, you can easily use Photoshop or a similar program to save it into 4:4:4, 4:2:2, or 4:2:0.

4:2:0 is the most common format for Jpegs and it's what most programs use.
Eric
Site Admin
 
Posts: 2636
Joined: Wed Apr 09, 2014 9:28 pm

Re: Some pics are not played by "JPEG Folder" block

Thu Oct 03, 2019 2:30 pm

Thanks a lot for helping me out :)
thedoger82
 
Posts: 3
Joined: Wed Oct 02, 2019 4:58 pm

Return to General Discussion

© 2019 Color & Music, LLC • This web site is mobile-friendly