jpegFolder not showing OSX-Preview processed images

Fri Jan 25, 2019 6:34 pm

Great Program ! I am enjoying exploring all the possibilities. Being able to bring in Blender 3D is brilliant.

Mac Pro 10.11.6 Magic v2.21

I am having an odd problem with jpegFolder media tool. JPEG images from my camera, exported from Photos, and images download from the internet, work fine. If I open any image with Preview (which is my usual work flow) they no longer appear in the jpegFolder tool but just a black screen for that image; images untouched by Preview still appear. I can see no difference in the files.

Admins-Mac-Pro:~ fritz$ file ~/desktop/pix2/doesnot.jpeg
/Users/fritz/desktop/pix2/doesnot.jpeg: JPEG image data, JFIF standard 1.01
Admins-Mac-Pro:~ fritz$ file ~/desktop/pix2/works.jpg
/Users/fritz/desktop/pix2/works.jpg: JPEG image data, JFIF standard 1.01
Admins-Mac-Pro:~ fritz$

Any suggestions would be appreciated.

Cheers
virionfritz
 
Posts: 4
Joined: Fri Jan 25, 2019 6:10 pm

Re: jpegFolder not showing OSX-Preview processed images

Fri Jan 25, 2019 7:07 pm

Can you please upload the jpegs as an attachment or post links so I can download and test them?
Eric
Site Admin
 
Posts: 2401
Joined: Wed Apr 09, 2014 9:28 pm

Re: jpegFolder not showing OSX-Preview processed images

Sat Jan 26, 2019 5:28 pm

Here is a link to the 3 examples: Works out of Photo, works right from Camera, and does not work after handled by Preview.

https://www.fritzherold.com/tools/index.php/s/aGqNdnE5oDxmjjX

And all images work and processed by Preview through Media and Images just not JpegFolder. I initially tried different locations and folders to finally note the apparent relationship to the being processed by OSX Preview. Simply Odd?

Cheers
virionfritz
 
Posts: 4
Joined: Fri Jan 25, 2019 6:10 pm

Re: jpegFolder not showing OSX-Preview processed images

Sat Jan 26, 2019 11:01 pm

Every program I've tried on Windows can view the image including the image module in Magic but I can confirm that the image in question doesn't work for me either in the jpeg folder module. The only thing I can see that is different between this file and other jpgs is that it doesn't seem to have chroma subsampling present in all other images. When re-encoded from another program it has chroma subsampling and also displays in the jpeg folder module.
Sadler
 
Posts: 518
Joined: Sat Aug 02, 2014 7:10 pm
Location: London, UK

Re: jpegFolder not showing OSX-Preview processed images

Sun Jan 27, 2019 4:09 pm

Ok, I looked into this, and the images that do not work have 4:4:0 chroma subsampling. The JpegFolder module is a highly specialized module for hardware-accelerated decompression of Jpegs, and 4:4:0 cannot be fully hardware accelerated.

The images that do work have 4:2:0 chroma subsampling, which is generally considered the standard.

So unfortunately there's nothing that can be done. It's best not to think of the JpegFolder module as a general-purpose Jpeg viewer. For that, the Image module can be used.

An important question is, why does OSX Preview re-save the images? If it's just an image viewer, it shouldn't. Perhaps there is a setting that can be changed.
Eric
Site Admin
 
Posts: 2401
Joined: Wed Apr 09, 2014 9:28 pm

Re: jpegFolder not showing OSX-Preview processed images

Mon Jan 28, 2019 10:01 pm

Thank You for the support and heads up, I do appreciate it. I use OSX Preview to do final resizing and colour matching for a bunch of images in batch; but I will dig into why it would make that change to the images.

And again that you for a super tool I'm having lots of fun with.

Cheers
virionfritz
 
Posts: 4
Joined: Fri Jan 25, 2019 6:10 pm

Re: jpegFolder not showing OSX-Preview processed images

Mon Jan 28, 2019 11:04 pm

An FYI for anyone needing to adjust Chroma subsampling ratios of individual or patch jpeg images: GIMP in the export to Jpeg under advanced setting allows you to change the ratios.

I have been unable to find out why OSX Preview viewer/editor sets all jpegs to 4:4:0 and where to set another default.

Cheers
virionfritz
 
Posts: 4
Joined: Fri Jan 25, 2019 6:10 pm

Return to General Discussion

© 2019 Color & Music, LLC • This web site is mobile-friendly