No audio with Video File

Thu Mar 22, 2018 2:39 am

Hey all. I am trying to use magic as a video switcher for a project. Problem I am having is that I am not getting audio output from any of the video files I try to play. I can see the video playing, but I get no audio from the video. I am using the media\videofile module to play the video.

How can I have Magic play the audio that is in the video file? I can't seem to figure it out.

Thanks
mlburgoon
 
Posts: 6
Joined: Wed Dec 13, 2017 2:04 am

Re: No audio with Video File

Thu Mar 22, 2018 3:17 am

I don't think Magic will do what you want, especially if you need audio as well as video switching.

Magic doesn't play the audio from a video file (although that feature has been requested several if not many times). You can extract the audio to a separate file then add that file in the Input Sources Window, but you can't then do the audio switching.

You could switch vision between several sources, but you would have continuous sound from just one of them.
Terry Payman
 
Posts: 504
Joined: Sun Sep 14, 2014 8:15 am
Location: UK

Re: No audio with Video File

Thu Mar 22, 2018 3:23 am

... and you could loop each video, restarting it every time it was selected, but the sound wouldn't loop until it had completely finished playing the entire audio from beginning to end.

I think you'd need to use MIDI to control an external DAW/sequencer to play the appropriate audio and control Magic to do the video switching.
Terry Payman
 
Posts: 504
Joined: Sun Sep 14, 2014 8:15 am
Location: UK

Re: No audio with Video File

Thu Mar 22, 2018 12:11 pm

Well, it does everything I need it to, except play the audio.

I create a scene for each video clip, then use OSC commands to switch to switch to what ever video clip I want to go to. Works great for the (currently) 6 video clips i had to test with. But no audio.... I guess I will have to find a workaround.

Thanks
mlburgoon
 
Posts: 6
Joined: Wed Dec 13, 2017 2:04 am

Re: No audio with Video File

Tue Nov 27, 2018 4:17 pm

same problem here: need audio & video
underscore
 
Posts: 5
Joined: Tue Nov 27, 2018 9:42 am

Re: No audio with Video File

Tue Nov 27, 2018 4:54 pm

Unfortunately we don't have any plans to make the VideoFile module play audio. Probably your best bet is to use a different application. If you still want to use Magic for certain things, you can connect it via Spout or Syphon if the other app supports them.
Eric
Site Admin
 
Posts: 2444
Joined: Wed Apr 09, 2014 9:28 pm

Re: No audio with Video File

Tue Nov 27, 2018 8:34 pm

Thank you - did not know that Syphon supports audio. What player do you recommend?
underscore
 
Posts: 5
Joined: Tue Nov 27, 2018 9:42 am

Re: No audio with Video File

Wed Nov 28, 2018 1:48 am

No, Syphon doesn't support audio. What I meant is that you can use another program to play video/audio, and then either send the video to Magic via Syphon, or receive visuals in that program from Magic via Syphon.

I can't really provide a recommendation to you because I never play audio from video files, but if you go to the Syphon web site, you can find an exhaustive list of all the apps that support Syphon: http://syphon.v002.info/
Eric
Site Admin
 
Posts: 2444
Joined: Wed Apr 09, 2014 9:28 pm

Re: No audio with Video File

Wed Nov 28, 2018 6:10 am

So I am basically stuck here ... successfully build VLCSyphon and use Soundflower for audio but just discovered that I licensed a Magic version w/o Syphon input ...
underscore
 
Posts: 5
Joined: Tue Nov 27, 2018 9:42 am

Re: No audio with Video File

Wed Nov 28, 2018 3:56 pm

Ah yes, sorry about that. You would need to upgrade your license in order to get the Syphon functionality, if that's what you want to do. https://magicmusicvisuals.com/upgrade
Eric
Site Admin
 
Posts: 2444
Joined: Wed Apr 09, 2014 9:28 pm

Re: No audio with Video File

Sun Dec 02, 2018 11:00 am

get the Syphon output now, while input from VLCSyphon is still missing. Any hints?
underscore
 
Posts: 5
Joined: Tue Nov 27, 2018 9:42 am

Re: No audio with Video File

Sun Dec 02, 2018 11:44 am

Sorry, found it under "special" modules while I was first looking in the "source" window.
underscore
 
Posts: 5
Joined: Tue Nov 27, 2018 9:42 am

Return to General Discussion

© 2019 Color & Music, LLC • This web site is mobile-friendly